Zurück   HTML Forum > Linux > Debian

Debian Fragen und Antworten rund um das Betriebssystem Debian.

Neues Thema erstellen  Antwort
 
Themen-Optionen Thema durchsuchen
Alt 29.05.2009, 23:03   #1
Administrator
 
Benutzerbild von developr
 
Registriert seit: 11.11.2008
Ort: Bremen
Beiträge: 330
developr eine Nachricht über ICQ schicken developr eine Nachricht über MSN schicken
Standard The following packages have been kept back

Trotz ein apt-get dist-upgrade werden nun einige Pakete zurückgehalten. Eigentlich wollte ich für mein Trackingsystem, welches ich gerade entwickel, php5-geoip installieren. Das Paket wiederrum benötigt eine aktualisierte Version von libc6.

Hat jemand einen Rat, wie ich die ganzen Pakete trotzdem aktualisiert bekomme?

Es handelt sich übrigens um ein Debian Etch System.

Code:
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages have been kept back:
  libapache2-mod-php5 libmysqlclient-dev libmysqlclient15-dev libmysqlclient16 php5 php5-apc php5-cli php5-common php5-curl php5-dev php5-gd php5-mysql
0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.
Code:
apt-get install php5-geoip
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-geoip: Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch9 is to be installed
              Depends: php5-common (= 5.2.9-0.dotdeb.2) but 5.2.8-0.dotdeb.1 is to be installed
E: Broken packages
developr ist offline   Mit Zitat antworten
Neues Thema erstellen  Antwort

Stichworte
apt, apt-get, debian, dist-upgrade, etch, geoip, libc6, linux, upgrade
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.